Apple App Store API Performance Degradation

Incident Report for RevenueCat

Resolved

We are still seeing unusual traffic patterns from Apple, however we have a mitigation in place to ensure there is no impact to stability.

Since it has been stable for a few hours now, we are closing out this incident.
Posted Sep 23, 2025 - 06:53 UTC

Identified

We are currently experiencing unusual request patterns related to Apple's App Store APIs. Additionally, Apple has opened an incident on their status page stating that the App Store is currently having performance issues.

So far this has not impacted RevenueCat's reliability, but we will keep this incident open until we are in the clear.
Posted Sep 23, 2025 - 03:08 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).