Problem with non subscriptions products in Google Play
Incident Report for RevenueCat
Resolved
All purchases were replayed. Marking the incident as resolved
Posted Apr 30, 2024 - 20:36 UTC
Monitoring
The release is now live and non subscription purchases on Google should be working as expected. We are working on replaying all failed to process purchases
Posted Apr 30, 2024 - 12:09 UTC
Update
We have just merged the fix to handle this unexpected change. Going through the release pipeline
Posted Apr 30, 2024 - 11:13 UTC
Update
Updated status page title to reflect impact. Non subscription products are impacted. We are working on a fix. Will replay the purchases once the fix is live
Posted Apr 30, 2024 - 09:53 UTC
Identified
We have identified the issue. There was a change in the response from Google that made us wrongly process consumable purchases. We are working on a fix
Posted Apr 30, 2024 - 09:22 UTC
Investigating
We have reports of google consumables not working for some customers. We are investigating
Posted Apr 30, 2024 - 08:14 UTC
This incident affected: App Store Receipt Servers (Google Play Store Receipt Server).