Delayed integration event dispatching

Incident Report for RevenueCat

Resolved

We have caught up on receipts likely to have expirations or renewals and are performing other refreshes at a healthy pace now.
Posted Sep 26, 2025 - 14:16 UTC

Identified

From 7:30 UTC to 10:30 UTC event dispatching was delayed for expiration, transfer, cancellation and renewal events due to an infrastructure issue.

For apps with server-to-server notifications enabled, there shouldn't have been a noticeable delay. For apps without server-to-server notifications, we are catching up on delayed events.
Posted Sep 26, 2025 - 10:53 UTC
This incident affected: Event Dispatching.