Issue has been fixed, sorry for the inconvenience.
Posted Nov 14, 2024 - 10:16 UTC
Investigating
We are currently investigating an issue with the RevenueCat dashboard (app.revenuecat.com) not loading correctly. API traffic (including apps using the RevenueCat SDK) are not impacted.
Posted Nov 14, 2024 - 10:14 UTC
This incident affected: Dashboard (Customer Lists, Overview, Charts).