Offer code pricing is reported with price 0 for Apple transactions
Incident Report for RevenueCat
Resolved
Apple has fixed the issue on their side, and we have fixed the Apple store transactions that were affected so prices with redeemed offer codes are now being reported accurately.
Posted Dec 15, 2023 - 04:21 UTC
Update
Apple is working on the fix. Their change is live in sandbox and they are working on fixing production
Posted Dec 14, 2023 - 22:48 UTC
Update
We got confirmation that Apple is aware of the issue
Posted Dec 14, 2023 - 11:48 UTC
Identified
We have identified that the issue comes from Apple side, we reported the issue to them and we are waiting for them to fix it. Based on our records, it seems that it started on 2023-12-13 around 20:00 PM UTC.

We'll keep the incident open until we hear from them
Posted Dec 14, 2023 - 11:10 UTC
Investigating
We are seeing a number of Apple store transactions that have redeemed an offer code and the price is reported as 0 even when everything is configured correctly.
Posted Dec 14, 2023 - 10:39 UTC