Increased error rate when fetching subscriber information

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted May 25, 2026 - 17:29 UTC

Monitoring

A fix has been implemented and error rate is going down. We'll keep monitoring.
Posted May 25, 2026 - 16:23 UTC

Identified

We are experiencing an increased error rate when fetching subscriber information coming from an incorrect cache. We are currently working on a fix.
Posted May 25, 2026 - 15:57 UTC