Apple Store Kit 2 elevated error rates

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 14:13 UTC

Monitoring

We have stopped getting errors from Apple Store Kit 2 and the service is operational. We will continue monitoring all the systems.
Posted Jul 07, 2026 - 11:40 UTC

Investigating

We are getting 5xx errors when calling Apple Store Kit 2 to validate receipts. We have enabled mitigations to keep customer purchases uninterrupted and we are investigating the issue.
Posted Jul 07, 2026 - 10:32 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).