Delayed Charts v3 Data

Incident Report for RevenueCat

Resolved

We identified and resolved the issue. Charts v3 data is now up-to-date.
Posted May 12, 2026 - 07:24 UTC

Investigating

We're investigating an issue where charts v3 data is delayed
Posted May 12, 2026 - 04:01 UTC
This incident affected: Dashboard (Charts).