Apple reporting old receipts inBillingRetryPeriod - mitigated - no customer impact
Incident Report for RevenueCat
Resolved
The bug on Apple’s side is not yet resolved, but with the mitigation we have in place the impact remains negligible.
Particularly, in very rare cases, “Billing Issue” events with wrong timing may appear in RC dashboard and ETL exports. Those events will not be dispatched to integrations such as Webhooks.

Provision of Entitlements, subscriptions status and other critical functionalities are completely unaffected.

We consider the issue solved for Revenue Cat customers but we will continue seeking updates from Apple for the resolution of the root cause.
Posted Jul 18, 2024 - 15:49 UTC
Update
Since July 16 at 23:30 UTC we started getting a significantly lower amount of problematic receipts. There is no official answer about the issue from Apple yet. Our mitigation is still enabled and we keep tracking the issue. We will be updating this status page with any news.
Posted Jul 17, 2024 - 09:28 UTC
Update
We are continuing to monitor the situation and our fix mitigated the old receipts that were being marked as “with billing issues” due to Apple returning isInBillingRetryPeriod for them.

The involved receipts are old and they won’t affect the current user entitlements or subscription statuses.
They were causing an increased number of events on our side since we constantly refresh them to keep their status up to date and catch differences.
Posted Jul 16, 2024 - 20:29 UTC
Monitoring
We applied a mitigation to the issue.
We are temporarily ignoring the changes sent by Apple that we believe to be wrong. Namely, the isInBillingRetryPeriod field is being incorrectly set to true for long expired transactions.
We are keeping track of all the affected transactions and we will make sure to update them with accurate data once the issue is resolved by Apple.
We will keep monitoring the situation and we’ll update this incident as soon as the situation is solved on Apple side.
Posted Jul 16, 2024 - 14:37 UTC
Identified
We identified the issue in a change happening on Apple side.
We notified Apple and we are working on a mitigation to reduce the impact until they provide a fix.
Posted Jul 16, 2024 - 13:37 UTC
Investigating
We noticed a significant increase of billing issues for long ago expired purchases reported by Apple APIs. We are suspecting a malfunction on Apple's systems and have already reported it.

We will keep tracking the issue and look for possible mitigations on our side.
Posted Jul 16, 2024 - 09:15 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).