Elevated Google Play API Error Rate

Incident Report for RevenueCat

Resolved

Google has closed out their incident. We haven't observed any errors since 15:54 UTC.
Posted Jul 18, 2025 - 18:22 UTC

Update

Google has acknowledged the incident. We keep monitoring. We do not see any errors anymore.

https://status.cloud.google.com/incidents/8cY8jdUpEGGbsSMSQk7J
Posted Jul 18, 2025 - 16:11 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 18, 2025 - 16:05 UTC

Monitoring

We do not see elevated errors any more. We keep our mitigations in place and will keep tracking the issue.
Posted Jul 18, 2025 - 15:54 UTC

Identified

We are observing elevated error rates with the Google Play API. We have enabled granting temporary entitlements for impacted customers to mitigate any purchasing issues so customers can keep purchasing.
Posted Jul 18, 2025 - 15:37 UTC
This incident affected: App Store Receipt Servers (Google Play Store Receipt Server).