Problem with Consumables using Google Play Store
Incident Report for RevenueCat
Resolved
All purchases were replayed. Marking the incident as resolved
Posted Feb 20, 2024 - 14:21 UTC
Monitoring
We have released a fix to Google Play Store consumables. We are working on replaying all purchases from the past few days that did not go through.

If end users are not seeing their purchases, a restore will also fix it
Posted Feb 20, 2024 - 00:27 UTC
Update
Some updates:
- We believe this is affecting ~10% of non-subscription purchases on Android
- Google began, randomly, responding with the an incorrect error message on an API we use to determine if a purchase is a subscription or not.
- We're rolling out a change that handles the Google error.
- Following the deploy of the change, we will reprocess any receipts and should be able to correct most if not all instances of the issue.
Posted Feb 20, 2024 - 00:08 UTC
Identified
There was a change on Google's endpoint that made RevenueCat not process consumables purchases correctly, releasing a fix
Posted Feb 19, 2024 - 23:02 UTC
Investigating
We are seeing reports from customers that there are problems with consumables in Google Play Store. We are investigating
Posted Feb 19, 2024 - 22:44 UTC
This incident affected: App Store Receipt Servers (Google Play Store Receipt Server).