ARR/MRR charts are incorrect for some users

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:44 UTC

Update

We have applied the fix, and we are currently backfilling the affected charts.
Posted Mar 31, 2026 - 15:43 UTC

Update

We have found that the issue only affects charts for Play Store products that have two introductory offers. We are currently testing our fix before the final deployment and backfilling of the affected charts.
Posted Mar 31, 2026 - 12:42 UTC

Identified

We have identified a problem affecting the Play Store which results in inflated MRR/ARR numbers for Charts v3. We have identified the problem and we are working on a fix.
Posted Mar 31, 2026 - 09:59 UTC
This incident affected: Dashboard (Charts).