Webhook delivery is delayed

Incident Report for RevenueCat

Resolved

Webhook delivery latency is still on normal levels and the system is stable. We consider the incident resolved.
Posted Aug 07, 2026 - 19:54 UTC

Monitoring

Webhook delivery latency is back down to normal levels.
Posted Aug 07, 2026 - 17:29 UTC

Identified

We are seeing increased latency on webhook delivery and are working to mitigate
Posted Aug 07, 2026 - 16:47 UTC
This incident affected: Event Dispatching.