Apple StoreKit 1 increase errors
Incident Report for RevenueCat
Resolved
We have replayed all the purchases, and the incident is now resolved.
Posted Mar 18, 2024 - 23:18 UTC
Update
After some troubleshooting, we realized that the problem was on our side affecting that small percentage of requests. Our internal metrics were wrongly reporting that the problem was on Apple's side.

We are replaying all requests to make sure no purchases were lost
Posted Mar 18, 2024 - 19:04 UTC
Update
We are still seeing connection errors on Apple side when using StoreKit 1 - it bounces between 5% and 10% of those requests
Posted Mar 18, 2024 - 17:01 UTC
Monitoring
We are monitoring the problem. Seems that Apple is recovering. We'll continue to monitor the situation and once it's fully recovered, we'll replay all purchases that failed during that period.

If users are affected, they will be able to resolve by restoring purchases or re opening the app
Posted Mar 18, 2024 - 14:03 UTC
Identified
All errors are coming from Apples' Servers - Connection Timeouts
Posted Mar 18, 2024 - 14:01 UTC
Investigating
We are seeing a low percentage (~7%) of failures on POST /receipts using Apple - StoreKit 1
Posted Mar 18, 2024 - 13:59 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).