Apple Sandbox Environment Instability
Incident Report for RevenueCat
Resolved
The sandbox environment appears to have stabilized so we're marking this issue as resolved.
Posted Apr 22, 2020 - 18:40 UTC
Update
We're continuing to monitor the issue and still seeing periods of ~50% failure rates.
Posted Apr 09, 2020 - 18:18 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 27, 2020 - 17:21 UTC
Monitoring
Since roughly 3/22 the App Store Sandbox environment has been undergoing some instability for several hours each day. As far as we can tell, this isn't affecting anything in production. We've observed periods of ~50% failure rates last 4 hours, usually between 0800GMT and and 1200GMT.

We've also been hearing reports of other functions of the sandbox, such as fetching products and making purchases are seeing errors and resulting in App Review rejections. We don't have direct visibility into this but it seems to be a pattern.

We've reported the issue to Apple and will continue to monitor the situation.
Posted Mar 27, 2020 - 17:21 UTC
This incident affected: App Store Receipt Servers (Apple Sandbox Receipt Server).