Spike of errors coming from Apple receipts server
Incident Report for RevenueCat
Resolved
This incident has been resolved.
Posted Apr 13, 2023 - 21:56 UTC
Update
Service are operational but we'll keep monitoring the situation
Posted Apr 13, 2023 - 19:31 UTC
Monitoring
Apple's servers seem to have recovered, we are not getting elevated errors from App Store Servers anymore. We have gone to regularly processing purchases and we are monitoring the situation closely.
Posted Apr 13, 2023 - 19:14 UTC
Identified
We are mitigating the issue by granting entitlements without verifying receipts through Apple's servers to ensure that end customers get access to their purchases and will verify the purchases with Apple once Apple's servers have recovered.
Posted Apr 13, 2023 - 19:02 UTC
Investigating
We are seeing an increase of errors coming from Apple's App Store servers, impacting purchases in production. We are monitoring if Apple's servers will recover and investigating ways to mitigate the impact for RevenueCat customers.
Posted Apr 13, 2023 - 18:30 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).