Apple sandbox errors with "There is no information for In-App Purchases" message
Incident Report for RevenueCat
Resolved
We no longer see this error in our testing and have received reports that this has been resolved. If you're still getting this error when testing in sandbox, please reach out to support: https://app.revenuecat.com/settings/support.
Posted Nov 28, 2023 - 01:04 UTC
Investigating
Testing in-app purchases in new apps in sandbox can result in an error from Apple stating "There is no information for In-App Purchases". This issue appears to be on Apple's end and only in sandbox. Current workarounds include testing using StoreKitTest framework: https://www.revenuecat.com/docs/apple-app-store#ios-14-only-testing-on-the-simulator

We've filed a bug report with Apple and are continuing to monitor the situation.
Posted Nov 22, 2023 - 20:14 UTC
This incident affected: App Store Receipt Servers (Apple Sandbox Receipt Server).