API Availability

Incident Report for RevenueCat

Resolved

All requests have been re-processed.
Posted Feb 05, 2025 - 12:29 UTC

Update

We are currently re-processing all the API requests that were falling back to our back-up systems during the incident to make sure no data is lost.
Posted Feb 05, 2025 - 10:03 UTC

Update

Our APIs are operating normally now. We keep moniroring.
Posted Feb 05, 2025 - 09:45 UTC

Monitoring

We have mitigated the issue and now gradually going back to normal operation of our systems.
Posted Feb 05, 2025 - 09:41 UTC

Update

We are rolling back a release that might have caused the issue. We are continuing to investigate this issue.
Posted Feb 05, 2025 - 09:11 UTC

Investigating

We are investigating an issue with one of our database that's affecting RevenueCat API. We have enabled enabled emergency mitigations.
Posted Feb 05, 2025 - 09:10 UTC
This incident affected: API Uptime, Event Dispatching and Dashboard (Customer Lists, Overview, Charts).