App Store Connect undergoing maintenance by Apple

Incident Report for RevenueCat

Resolved

Apple has completed their maintenance.
Posted Aug 08, 2026 - 15:39 UTC

Monitoring

Apple has scheduled a maintenance window of App Store Connect on Saturday 2026/08/08 between 12:30pm to 3:00pm UTC.

New and existing production purchases will be unaffected. Sandbox purchases might be affected.

We also expect some features in the RevenueCat Dashboard, such as importing products automatically from App Store Connect or auto-applying settings from App Store Connect, may not function correctly during this time window.
Posted Aug 06, 2026 - 14:49 UTC
This incident affected: App Store Receipt Servers (Apple Sandbox Receipt Server) and App Store Connect API.