The issue has been resolved. We’re now making sure that any purchases affected by the outage are reprocessed.
Posted Sep 01, 2026 - 13:43 UTC
Monitoring
Apple has reported that the issue is now resolved, and we’re also seeing error rates return to normal. We’ll keep monitoring.
Posted Sep 01, 2026 - 13:31 UTC
Identified
We’re seeing an increased rate of errors when communicating with Apple’s backend services. This is resulting in some HTTP 522 responses from our receipts endpoint. We’ve enabled mitigations to minimize the impact on RevenueCat customers, and no purchases are currently being blocked as a result.
We’ll continue monitoring the issue and update this thread.
Posted Sep 01, 2026 - 13:17 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).