Small sample of delayed or Inaccurate Data in Charts, Experiments, and Data Exports for ~.2% of developers

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Jan 24, 2026 - 22:49 UTC

Update

We have resolved an issue that was preventing some deleted records from syncing to Charts, Experiments, and Scheduled Data Exports. The fix has been deployed and data is now flowing correctly. The vast majority of customers were not impacted. We are continuing to monitor the systems
Posted Jan 24, 2026 - 13:13 UTC

Monitoring

We have identified and fixed the issue preventing deleted records from syncing to our analytics products. Deletes are now flowing correctly. We are processing a backlog of data to ensure Charts, Experiments, and Scheduled Data Exports reflect accurate information.
Posted Jan 24, 2026 - 09:40 UTC

Identified

We have identified the root cause of the issue affecting Charts, Experiments, and Scheduled Data Exports. A recent configuration change was preventing deleted records from being synced correctly. We are now deploying a fix and will continue to monitor the systems.
Posted Jan 24, 2026 - 08:31 UTC

Investigating

We are investigating an issue affecting our analytics pipeline that is causing delayed or inaccurate data in Charts, Experiments, and Scheduled Data Exports. Deleted records are not being properly removed from these products. We are actively working to identify the root cause and will provide an update once we have more information.
Posted Jan 24, 2026 - 08:24 UTC
This incident affected: Dashboard (Charts) and Scheduled Data Exports.