Delayed data in Scheduled Data Exports and Charts

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 06:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 02, 2025 - 06:47 UTC

Monitoring

Identified an issue in our data pipeline that caused a delay in the data in Charts and Scheduled Data Exports. Data is being updated normally now, we will be monitoring until all data is fresh
Posted Oct 01, 2025 - 09:34 UTC
This incident affected: Dashboard (Overview, Charts) and Scheduled Data Exports.