App Store Connect outage

Incident Report for RevenueCat

Resolved

App Store Connect issues are now resolved.
Posted Jun 23, 2026 - 21:29 UTC

Monitoring

App Store Connect is experiencing degraded performance. Our users may experience issues when handling their app store products on the dashboard or on MCP. This does not impact purchases.
Posted Jun 23, 2026 - 19:50 UTC

Identified

App Store Connect is experiencing an outage that affects some users. Our users may experience issues when handling their app store products on the dashboard or on MCP.
Posted Jun 23, 2026 - 17:10 UTC
This incident affected: App Store Connect API.