App Store Connect degraded performance

Incident Report for RevenueCat

Identified

App Store Connect is experiencing slow response times, which may affect some users. They may encounter delays or issues when managing App Store products in the dashboard or through MCP.
Posted Jul 16, 2026 - 18:43 UTC

Investigating

App Store Connect is experiencing slow response times, which may affect some users. They may encounter delays or issues when managing App Store products in the dashboard or through MCP.
Posted Jul 16, 2026 - 13:47 UTC
This incident affects: App Store Connect API.