Stripe transaction revenue is not being correctly reported
Incident Report for RevenueCat
Resolved
Data has been backfilled and will be corrected in charts, subscriber lists, and scheduled data exports (aka ETLs) as those systems are refreshed throughout the day.

Customers with scheduled data exports will automatically get the new, corrected transactions in their next export.

For other integrations (webhooks, etc) if you would like to know specific details with regards to the impact on your project please don’t hesitate to reach out and we can answer questions or concerns.

We apologize for any inconvenience caused and will be following up with additional end-to-end testing coverage to prevent similar issues in the future.
Posted Oct 04, 2023 - 14:21 UTC
Monitoring
The fix has been fully rolled out and data looks good.

We will now work on backfilling impacted transactions, the incident will remain open until that is complete.
Posted Oct 04, 2023 - 05:27 UTC
Identified
We have found the cause, a fix will be going out momentarily.

This impacts any Stripe transactions ingested by RevenueCat after 2:39 AM UTC on October 3rd.

No data was lost, we will update impacted transactions with the correct prices. This incident will remain open until that backfill is complete.

Additionally, entitlement unlocking is not impacted.
Posted Oct 04, 2023 - 04:13 UTC
Investigating
Stripe transactions are currently reporting zero revenue when there should be tracked revenue.

We are investigating and will report additional details once we have more.
Posted Oct 04, 2023 - 03:49 UTC
This incident affected: API Uptime, Scheduled Data Exports, Event Dispatching and Dashboard (Customer Lists, Overview, Charts).