Investigating delayed product fetching from the App Store in sandbox

Incident Report for RevenueCat

Resolved

We're no longer seeing these intermittent delays in our own testing, or in reports from developers, so we're consider this incident resolved. If you see any unexpected delays in your own sandbox or TestFlight testing, please feel free to reach out to us for assistance.
Posted May 02, 2025 - 20:25 UTC

Monitoring

Sandbox, TestFlight, and App Review environments all appear to be intermittently affected by delays fetching products and displaying the pay sheet on the App Store's side. We'll continue monitoring to see if these delays subside.
Posted May 02, 2025 - 15:01 UTC

Update

TestFlight product fetching and purchase sheet display both seem to be experiencing displays. These delays appear to be isolated to TestFlight as far as we've observed.
Posted May 02, 2025 - 14:55 UTC

Investigating

We're seeing reports and examples of delayed product fetching for App Store apps in sandbox. We're currently investigating the problem, and will keep this incident updated as we learn more.
Posted May 02, 2025 - 14:48 UTC