Real-time Charts (beta): Active Customers chart and Overview dashboard have delayed data

Incident Report for RevenueCat

Resolved

We have finished processing the data backlog. Real-time charts now show up-to-date information in the Active Customers chart and the Overview panel.
Posted Nov 04, 2025 - 22:53 UTC

Monitoring

We have identified the root cause of the issue and are processing the backlog of data. The Active Customers charts (currently in beta) and Overview panel will start showing up-to-date information within 24 hours.
Posted Nov 03, 2025 - 20:12 UTC

Identified

We’re currently experiencing a delay in data updates for the Active Customers chart and the Overview dashboard. Our team is actively working to bring the data up to date.
Posted Nov 03, 2025 - 17:12 UTC
This incident affected: Dashboard (Overview, Charts).