Android Renewal Data Delayed
Incident Report for RevenueCat
Resolved
All the renewal data is now caught up and the situation is mitigated. Charts will update with correct data in later this evening.
Posted Jul 31, 2020 - 23:16 UTC
Monitoring
We've deployed a workaround and the Android data should be current again within a few hours. Charts will take longer, should be fixed by tonight.

We believe the issue is related to an infrastructure change we did this week. We've rolled back the change and are going to investigate the root cause. However, the issue should be resolved.

We'll update again once the refreshing is caught up.
Posted Jul 31, 2020 - 21:57 UTC
Identified
We've identified an issue that is causing delays in recording renewals for Android subscriptions.

We're deploying a workaround now, but renewal data for Android on the dashboard and sent out via integrations will be delayed.

New purchases are unaffected, and users opening the app after a renewal will still have access.

We'll continue to investigate and update this issue as we know more.
Posted Jul 31, 2020 - 20:47 UTC
This incident affected: Dashboard (Overview).