Apple not honoring free trials
Incident Report for RevenueCat
Resolved
It appears most apps have returned to normal. We'll keep an eye on the situation but it looks as if free trials and intro offers are working for most apps.
Posted Jul 03, 2020 - 00:27 UTC
Monitoring
Free trials appear to be down for ~25% of apps from looking at data over the past 3 days. It appears to be random by app, but 100% reproducible in affected apps.

We'll continue to monitor the issue.
Posted Jul 02, 2020 - 18:26 UTC
Investigating
We are investigating an issue where Apple is not honoring free trials even for users that should be eligible.
Posted Jul 02, 2020 - 18:03 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).