Developers may be unable to import products on the dashboard

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 18:09 UTC

Identified

The issue has been identified and we're implementing a fix.
Posted Feb 17, 2025 - 17:42 UTC

Investigating

We're currently investigating an issue on the dashboard where developers are unable to import products.

There are multiple paths that are still working. We recommend using the Import button that is available on the App section.
Posted Feb 17, 2025 - 17:27 UTC