Investigating issues with test mode in new Stripe accounts

Incident Report for RevenueCat

Resolved

Test mode isn’t available on new Stripe accounts that haven’t verified their business details.

This means you won’t be able to connect unverified Stripe sandbox accounts to RevenueCat. Older test accounts or accounts that are already verified aren’t affected.

To restore access to test mode, verify your business details in Stripe. We’re working on updates to support Stripe’s new sandbox behavior. These will be available soon.
Posted May 07, 2025 - 03:53 UTC

Investigating

We're getting reports from customers that test mode is not available for new Stripe accounts. We're investigating workarounds. You can still connect production Stripe accounts to RevenueCat.

Both Web Billing and Stripe Billing are affected only for sandbox purchases on new Stripe accounts. If you are affected, reach out to RevenueCat Support at support@revenuecat.com.
Posted May 06, 2025 - 18:40 UTC