Dashboard data including charts may be delayed by up to several hours
Incident Report for RevenueCat
Resolved
All the systems are now in operational state. We are marking the incident as completed but will continue monitoring all the systems. Sorry for the caused inconveniences.
Posted Dec 23, 2022 - 00:35 UTC
Update
We’ve partially resolved the issue and Charts, Overview, and ETL exports are now up to date. However Customer Attributes data is still delayed and may be out of date in ETL exports. We’re actively working to restore this functionality.
Posted Dec 21, 2022 - 14:19 UTC
Update
The data replication is still ongoing. Current lag is <5h.
Posted Dec 21, 2022 - 00:21 UTC
Update
The data replication is still ongoing. Current lag is <8h.
Posted Dec 20, 2022 - 23:37 UTC
Update
The data replication is still ongoing. Current lag is 24h.
Posted Dec 20, 2022 - 15:03 UTC
Update
The data replication is still ongoing. Current lag is 32h. At this rate we expect catchup in <24h.
Posted Dec 20, 2022 - 11:03 UTC
Monitoring
A fix has been implemented by our Cloud provider, and it's currently catching up. Our engineering team is assisting with monitoring the process and trying to coordinate with them to make the recovering as fast as possible.
Posted Dec 20, 2022 - 05:25 UTC
Update
Our cloud provider has acknowledged the issue and has been working on a fix that should be deployed shortly. In the meantime we are actively working on alternatives and contingency plans in case it gets delayed.
Posted Dec 19, 2022 - 20:19 UTC
Update
Our cloud provider is investigating and the issue was escalated to the service team.

We don't have an ETA for resolution at this point. The team is preparing contingency measures. We will update as soon as we have any news.
Posted Dec 18, 2022 - 22:32 UTC
Update
Update: unfortunately the replacement replication job appears to be experiencing the same issues. The issue is ongoing and we are waiting on assistance from our cloud provider.

Updates will continue as we can provide them, however there is currently no change to the status of this incident.
Posted Dec 18, 2022 - 14:01 UTC
Update
Update: engineers have found a suspected culprit in replication and are implementing a possible fix. We will update further as testing the fix proceeds.
Posted Dec 18, 2022 - 13:11 UTC
Update
We are continuing to investigate this issue.
Posted Dec 18, 2022 - 11:32 UTC
Investigating
Approx. UTC 0810 on December 18th, RevenueCat internal replication processes began experiencing failures. Affected systems include all systems related to dashboard and ETLs. Engineering investigation is ongoing; at this point we do not have an ETA to getting replication caught up.

During this incident, replication delays are causing all dashboards, charts, and ETLs to display outdated data. This incident affects RevenueCat developer visible systems only (dashboards).

We do not expect any impact to app subscribers, purchases, receipt validation or other core RevenueCat systems as a result of this issue.

This incident will be updated as investigation proceeds.
Posted Dec 18, 2022 - 11:31 UTC
This incident affected: Dashboard (Customer Lists, Overview, Charts) and Scheduled Data Exports.