Delays in data-related features
Incident Report for RevenueCat
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 05:47 UTC
Investigating
There's a delay in our data platform. We're actively investigating the issue
Posted Jul 01, 2022 - 04:58 UTC
This incident affected: Dashboard (Customer Lists, Overview, Charts) and Scheduled Data Exports.