Elevated Apple API Errors
Incident Report for RevenueCat
Resolved
Incident is resolved, Apple downstream error rates are back to normal and we're investigating failures in our mitigation attempts.
Posted Dec 12, 2024 - 22:01 UTC
Monitoring
Part of our Apple downtime mitigation process caused a secondary failure in our API, elevating the RevenueCat API error rates as well. This primarily affected get subscriber info and post receipt. SDK caches and redundancies will provide fallbacks for most cases, but S2S calls will also be affected.

Apple's servers have recovered and we're investigating the root cause of our mitigation failures.
Posted Dec 12, 2024 - 21:57 UTC
Identified
Apple's StoreKit 2 APIs are returning 5xx errors about 60% of the time, we've enabled RC Fortress™ so any purchases that do go through with Apple will process, however we are seeing issues on the purchasing side between the device and Apple that may depress purchase rates as well.
Posted Dec 12, 2024 - 21:35 UTC
Investigating
We're investigating an increase in errors from Apple's API.
Posted Dec 12, 2024 - 21:23 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).