Apple verifyReceipt endpoint instability
Incident Report for RevenueCat
Resolved
All failed receipts have now been replayed. This concludes the incident.
Posted Jun 11, 2020 - 14:04 UTC
Monitoring
The endpoint is now functioning correctly for both the sandbox and production environments.

We have disabled our temporary patch that enables 1-day promotional entitlements. In addition, we will be replaying any failed receipt requests that we have received during the outage.
Posted Jun 11, 2020 - 04:29 UTC
Update
We're still seeing instability on the App Store's verifyReceipt endpoint. The sandbox endpoint appears to be completely unreachable, the production endpoint is failing about 66% of the time.

We've deployed a patch that will temporarily grant users that attempt to purchase 1-day of entitlement access until we're able to re-validate receipts. As long as your app is using the RevenueCat Entitlements system new purchasers will be receiving the correct level of access.
Posted Jun 11, 2020 - 03:46 UTC
Investigating
Since roughly 0140GMT the App Store verifyReceipt endpoint has been undergoing some instability. As far as we can tell, sandbox environment has a higher failure rate (~95%) than production (~49%).

We will continue to monitor the situation.
Posted Jun 11, 2020 - 02:38 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server, Apple Sandbox Receipt Server).