Charts data freshness indicators showing outdated timestamps

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 20:27 UTC

Identified

We identified an issue where Charts data freshness indicators are displaying outdated timestamps. The underlying chart data is being updated correctly, but the freshness timestamps shown in the UI are not reflecting the latest refresh times. A fix has been deployed and we are monitoring the rollout.
Posted Jan 27, 2026 - 20:08 UTC
This incident affected: Dashboard (Charts).