Degraded Performance
Incident Report for RevenueCat
Resolved
Update: last seen data is fully restored and we are fully recovered. This resolves the incident. Engineers will continue monitoring, and will follow up internally with intention of preventing further recurrences.
Posted Mar 17, 2024 - 18:48 UTC
Update
Engineers have increased the capacity of the cluster which serves last seen data, and are bringing load back over to it gradually. We will update again when last seen data is enabled 100%.
Posted Mar 17, 2024 - 18:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2024 - 18:34 UTC
Update
Engineers have completed re-synchronizing purchases which were temporarily granted during the initial mitigation, and have restored RevenueCat's backend systems to their non-degraded state, with the exception of last seen data which is not being read or written.

As a result of this unplanned downtime and until further notice, last seen data may be missing from some responses and outdated in others. However, response times and success rates can be expected to be normal.

Engineers are working to bring back the systems that store and provide last seen information.
Posted Mar 17, 2024 - 17:26 UTC
Update
Most systems are back to normal. Only impacted problem that we haven't solved is last_seen fields. We are replaying all impacted purchases
Posted Mar 17, 2024 - 16:44 UTC
Identified
We've isolated the system causing the issue and disabled it. Service is slightly degraded
Posted Mar 17, 2024 - 16:29 UTC
Investigating
Our engineers detected degraded performance and performed an emergency mitigation while we investigate
Posted Mar 17, 2024 - 16:15 UTC