Some Play Store trials with non zero revenue
Incident Report for RevenueCat
Resolved
This incident has been resolved.
Posted Jun 30, 2023 - 16:58 UTC
Update
We have run a script to fix older data. This should be almost done. Will keep it in monitoring until we confirm all data is fixed
Posted Jun 28, 2023 - 12:39 UTC
Update
Fix gone live and working as expected. Only remaining work is fixing old data. Will close the incident once that is done
Posted Jun 27, 2023 - 12:13 UTC
Monitoring
We have release a fix that should prevent new CANCELLATION and BILLING_ISSUE events to report the wrong price. Once we confirm that the fix is working as expected, we'll work on fixing old transactions
Posted Jun 26, 2023 - 15:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 26, 2023 - 15:44 UTC
Update
A fix for the impacted data will be tested early next week. We’ll leave the incident open until that fix has been fully rolled out.

Impact: The corresponding CANCELLATION and BILLING_ISSUE events having price set for them when they shouldn't, and that price being reflected in our Scheduled Data Exports (ETLs) as well. Other systems are not affected.
Posted Jun 23, 2023 - 22:09 UTC
Update
We are still working on fixing the impacted data. We'll have more updates by end of day (CET time).

Impact: Some events having price set for them when they shouldn't, and that price being reflected in our Scheduled Data Exports (ETLs) as well. Other systems not affected
Posted Jun 23, 2023 - 09:28 UTC
Update
Fixes to our Overview metrics and our internal billing system amounts have been rolled out.
Our team is still working on calculating refund amounts to the impacted customers. We'll be individually notifying everyone impacted.

Our Scheduled Data Exports (ETL) and the corresponding events are still impacted. This fix will likely still take until early tomorrow morning (CET time).
Posted Jun 23, 2023 - 00:49 UTC
Identified
We’ve detected a set of trial to paid transaction attempts for developers using Play Store Billing Client 5 that were unsuccessful due to billing issues, but incorrectly had revenue associated with them in our system.

Data impact: This incorrectly set revenue resulted in the corresponding BILLING_ISSUE and CANCELLATION events having price set for them, and that price being reflected in our Scheduled Data Exports (ETLs) as well.
Other RevenueCat data features like Charts and Experiments were unaffected.

Billing impact: Our internal billing system was also affected.
If some of your transactions have been affected, a refund for the over-billed revenue will be automatically issued, and the data in your exports will be corrected in future runs.


We'll leave the incident open until we fully correct the issue,

If you have any questions, please don’t hesitate to reach out to us.
Posted Jun 22, 2023 - 19:39 UTC
Update
We are continuing to investigate this issue.
Posted Jun 22, 2023 - 18:30 UTC
Investigating
Our team is investigating an issue with a subset of our Play Store trial transactions, which are displaying non-zero revenue. We will update with more details soon
Posted Jun 22, 2023 - 18:29 UTC
This incident affected: Dashboard (Customer Lists, Overview) and Scheduled Data Exports, Event Dispatching.