Collaborator invite links do not work

Incident Report for RevenueCat

Resolved

We have confirmed that the fix works. Collaborators can now accept invitations through collaborator links even if they are not signed into the RevenueCat dashboard beforehand. If you notice any issues, please reach out to support@revenuecat.com.
Posted Jun 13, 2025 - 23:19 UTC

Monitoring

We deployed a fix. We are monitoring for any further issues.
Posted Jun 13, 2025 - 23:12 UTC

Update

We are still working on a fix.
Posted Jun 13, 2025 - 22:56 UTC

Identified

We've identified the issue and are working on a fix.
Posted Jun 13, 2025 - 22:22 UTC

Update

We are continuing to investigate this issue.
Posted Jun 13, 2025 - 21:41 UTC

Investigating

We're aware of an issue that inviting collaborators does not work if the collaborator is not already logged into a RevenueCat session in their browser. We're investigating and will have more updates to share soon.
Posted Jun 13, 2025 - 21:37 UTC
This incident affected: Dashboard (Collaborators).