Increased Latency in Integration Event Delivery

Incident Report for RevenueCat

Resolved

Latency in delivering integration events is back to normal.
We are reprocessing the events that failed to deliver during the GCP service degradation.
Posted Jun 12, 2025 - 22:50 UTC

Identified

The latency issue has been resolved and we are working on redelivering firebase and webhooks events that failed to dispatch.
Posted Jun 12, 2025 - 21:23 UTC

Investigating

There has been an increased delay in the delivery of integration events due to the ongoing GCP service degradation.
Posted Jun 12, 2025 - 20:45 UTC
This incident affected: Event Dispatching.