INITIAL_PURCHASE events being sent for renewals
Incident Report for RevenueCat
Resolved
Summary:
This incident impacted all iOS apps where a renewal happened between 2023-05-04 17:23 and 2023-05-05 10:36. No other platforms were impacted.
We are closing this incident as we have confirmed all data starting 2023-05-05 10:36 is correct.

What to expect next:
1. We will correct this data for all impacted customers early next week.
2. In order to avoid revenue duplication, we will not be resending the renewal events for webhooks and other integrations by default. If you would like us to resend the events or if you have any concerns related to your app or customers, please don’t hesitate to reach out to RevenueCat support.
Posted May 05, 2023 - 22:46 UTC
Monitoring
From 2023-05-04 17:23 to 2023-05-05 10:36 (17 hours), RevenueCat sent INITIAL_PURCHASE events for some renewals for webhooks and other integrations. We have reverted the change that caused this and are currently investigating the impact across customers and how to best recover the correct data.
Posted May 05, 2023 - 15:39 UTC
This incident affected: Event Dispatching.