Apple Receipt Server Outage
Incident Report for RevenueCat
Resolved
All purchases that failed during that outage have been revalidated and everything is back in sync.
Posted Jan 25, 2020 - 06:03 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 24, 2020 - 22:26 UTC
Update
The Apple receipt server is appearing to come back online for most regions. We're gathering logs now and are preparing to replay all of the purchases that previously failed.
Posted Jan 24, 2020 - 20:12 UTC
Monitoring
We've deployed a patch that will temporarily grant users that attempt to purchase 1-day of entitlement access until we're able to re-validate receipts. As long as your app is using the RevenueCat Entitlements system new purchasers will be receiving the correct level of access.
Posted Jan 24, 2020 - 18:28 UTC
Identified
We've identified an outage in Apple's purchase receipt verification endpoint that's effecting the majority of new purchases on iOS. We're closely monitoring the issue and will attempt to replay all of the purchases once their system stabilizes.
Posted Jan 24, 2020 - 14:22 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).