App Store apps failing to process purchases
Incident Report for RevenueCat
Resolved
All purchase information has been reprocessed, and no data has been lost.
If your users have been affected by these issues, they can recover their purchases by either restoring purchases or restarting the app.

Webhooks have been retroactively triggered for reprocessed purchases.
Posted Jan 29, 2024 - 23:38 UTC
Update
We are working recovering all purchase information by reprocessing all the purchases that failed while App store server-side APIs were down, so no data will be lost.
Posted Jan 29, 2024 - 18:56 UTC
Monitoring
Our metrics are reporting that App store has recovered. We'll keep the incident open monitoring their response
Posted Jan 29, 2024 - 18:49 UTC
Investigating
We detected that App Store server APIs are failing. Server-side receipt validation is not functional. Webhooks related to apple purchases are not triggered.
All purchases are recorded by RevenueCat and we will re-process them when Apple's servers are back online.

For RevenueCat SDKs that support Offline Entitlements, purchases will work as expected in the app and the user will get entitlements. More information about Offline Entitlements here: https://www.revenuecat.com/blog/engineering/introducing-offline-entitlements/

For older RevenueCat SDKs, purchases will be charged but won't be validated by our server, leading to an error.
Posted Jan 29, 2024 - 18:46 UTC
This incident affected: App Store Receipt Servers (Apple Receipt Server).